General Issues with Flash Video Playback

Chuck -

Some of our older sites require flash video players, if you see a broken "gear" or error that your flash player is out of date, this is likely a website that requires flash video player.

1. Check your internet speed, we require a minimum of 7MBPS download and 4MBPS upload. You can check your speed easily here:

2. If you are certain that you are still connected to the internet and speed is high enough, you may need to update to the latest version of Adobe Flash.  This software is available for free from Adobe’s website at

3. Some web browsers no longer support Adobe Flash, you can always try different browsers to see if this is the cause. Such as Firefox or Safari.

Have more questions? Submit a request


Article is closed for comments.